Jump to content
Edvard

LIML dramatic FPS drop at night

Recommended Posts

Hi, I bought LIML and are very impressed, but I noticed at night in P3D V4 (with dynamic lighting on) my FPS drops t 7 (!!), while it runs at an FPS of around 40 in daylight...

As soon as I switch over to another airport for example EHAM or LEBL, I don't have this problem.

 

Any ideas?

Ed van de Vijver

Share this post


Link to post
Share on other sites

Hello Ed,

Dynamic lights are demanding indeed, but there is no reason you should have such low FPS at LIML if you are getting good FPS everywhere else. Our dynamic lighting is made as simple as possible to avoid any FPS issue. We included only one emitter, and the effect file itself is very simple. A few steps can be done to hopefully improve the situation:

- delete your shaders cache: Go to C:\Users\yourname\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders   and delete the “shaders” folder (make a backup first). Next time you’ll start your P3D V4, shaders will be regenerated (this can take a up to a few minutes, your sim will look "empty" while regenerating, this is normal).
- I have noticed that sometimes you have to "play" with your view angle to get good FPS with dynamic lights. If you start at a gate for example, switch to external view, and then pan around for 10 seconds. In my case I suddenly get great FPS again (this was tested on both our airports and other developer's sceneries).
- make sure you don't use too much bloom in your lighting options. Mine is set at 0.30. Dynamic reflections are also better set to off.

Please let me know if there is any improvement,

Best regards,
Thomas

Share this post


Link to post
Share on other sites

Hi Thomas, thanks for your heads up.

I tried everything you mentioned. No result. Strange is that going outside makes FPS a bit better, but it fluctuates from 1,6 to 70 and everything in between. seems with a irregular interval of 1-3 seconds going up and down.

As soon as I switch to for example LEBL (by navigation choosing another airport) FPS is about 50 steady.

Share this post


Link to post
Share on other sites

This is very strange. When it comes to dynamic lights (DL), I have seen users having issues with some airport sceneries but not with other ones. So, most of our sceneries users will have good FPS with DL, but a few won't. Other editors will have the same issue as well.

We can try the following: start a flight by night at Gate 4 in VC view. Then press "Y" for slew mode and move your aircraft to  beginning of RWY 36. Now, slew back to gate 4 and check your FPS. There will hopefully be an improvement. I use this technique when sometimes I get FPS issues due to DL. Slewing far from the DL and coming back always solves the issue in my case.

Share this post


Link to post
Share on other sites

Hi Ed,

To be honest at the moment I don't know what could be the issue as I could not create this FPS problem on my computer. If needed I can provide you with files deleting the dynamic lights for the scenery as a temporary measure until I get a better idea of what's going on there. Please let me know.

Best regards,

Share this post


Link to post
Share on other sites

Hi,

confirm the problem :(

I have same issue with dl and LIML. For example, no problem at  EGLL or LOWW beta 2.8 (fly tampa). No problems also in Uk2000 apt's with dynamic lights update. At Liml have a dramatic fps drop. Any idea?

Share this post


Link to post
Share on other sites

Hi gianluk81, thank you for your feedback. Actually making the effect even smaller will make dynamic light useless as it won't put enough light around. I really have to understand why only a few users are having an issue with that DL.
There is a setting which makes DL very FPS heavy: if you are using an AA setting like 8xSSAA, this will be very FPS heavy by night. I recommend setting 8xMSAA.

Share this post


Link to post
Share on other sites

You have a better config than me (I got a GTX 1070 with I7 4770K), so you should have better FPS too. At Linate with DL activated I get an average of 40-50 FPS at night. So I will be looking at which setting or element which could harm your FPS with our DL on. I'll let you know as soon as possible if a solution is found.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×