Jump to content
Sign in to follow this  
Ted_Striker

Discovery

Recommended Posts

I know I have openly stated that running FSX on a laptop is very much possible, as well as holding 30fps with addons and such.  Something had been bugging me recently, and more specifically after installing Captain Sim products.  Now, I KNOW the consensus has stated that CS products tend to be a little heavy on the fps, but this was more with after a flight was completed, I would crash to desktop, not all the time, but enough to make me wonder what was wrong.  So, first thins was to check out my fsx cfg file, and this is what I found.  Since I have a laptop with an nVidia card, it has that wonderful feature called Optimus (I am being sarcastic), and so with that, my cfg file not only had the entry in it for my nVidia card, but that damned intel integrated graphics as well.  So, I delete it, fire up fsx and go to my settings and wouldn't you know it, my default graphics was set to the intel?  Btw, this optimus technology was made to transfer graphics processing power where needed, and since I am mostly running my laptop from one place, I leave it plugged in so i don't need any power saving features running....

 

At that point I was fuming...deleted the cfg file, fire up fsx, still showing up with intel graphics...go to nVidia control panel, everything is set for the graphics card.  I fire up fsx by right-clicking the icon and choosing my graphics processor to run as nVidia, go to settings, STILL showing as intel!

 

I had enough, uninstalled everything and then did some research.  I was specifically looking for a way to turn off the intel graphics and only run the card, but I found out that you cannot do that, but what you can do is set the global feature to always run the nVidia...haha, right, I already knew that.  So anywho, I reinstall fsx and also run the nVidia inspector, by way of a very good instructional on one of the flightsim websites and I see something I did not see before when it came to tweaking in the inspector.  Turns out, you can specifiy a specific profile just for FSX (there is even one for Flight Sim 2004).  Settting up a different profile was NOT something I did before.  I assumed that tweaking the base profile would be all I needed but after doing what was instructed with the tweaks and only doing a few small tweaks in the fsx cfg, I now proudly have fsx running off the nVidia card, maintaining 30fps, not major stutters and best of all, I can exit a flight without a crash.  In fact, when I end a flight and go back to the main menu, it is much quicker now.

 

So, in short, when using the inspector utility, make sure you specify the profile as THIS is what nvidia will want to use when you run fsx AND it will take over all processing.

 

Hope that all made sense.  If I come across that article again with the fsx cfg settings and nVidia inspector settings, I'll pass it along.

Share this post


Link to post
Share on other sites

My case is probably not so unique as the Optimus tech really didn't have much to do with my cfg woes.  What I wanted to stress is that when you use the nVidia Inspector, it is highly recommended to use the MS Flight Simulator X profile for your tweaks as a base.  using that profile tells the nVidia card that you are running fsx with it's graphics processing rather than the intel's.  The inspector will then divert all processing to the card and not rely on any usage of the intel integrated graphics, although since you have an "i" processor, you may also run into the issue (albeit behind the scenes) of your graphics switching back and forth.  A good way to check is to look for the entry in your cfg file that starts with [Display.xxxxx.xxx) and see if there is only one entry and that entry is for the nVidia card.  I found, before the reinstall, that I actually had two entries.  The first WAS the nVidia but due to the way the cfg adds entries as needed and doesn't not provide spaces to divide sections, the other entry for the intel graphics was buried down deeper.

 

Overall, this is an odd issue and maybe I am one of the few that has the problem but I thought I would share my findings with anyone who may not realize what could be happening.

Share this post


Link to post
Share on other sites

Well it won't do me any harm to change my nVidia Inspector to use the FSX profile - I only use the 1/2 vertical refresh rate tweak anyway.

 

Currently I have mostly been reinstalling the whole lot (OS, FSX every add on under the sun) after a bad bit of RAM wrongly lead me to assume that the hard drive was bad :rolleyes:

Share this post


Link to post
Share on other sites

Using the MS Flight Simulator X profile as a base for your tweaks is a good idea.  You can always create more profiles (not to mention backing up a profile, or exporting it as a backup) if you are trying to get the card to take care of a fsx issue.  As these are tweaks, you can always change them back or worse case, just reinstall inspector and set the card back to defaults.  I guess there was an initial intimidation factor for me prior to yesterday in using the inspector, but now that I see what it can do as well as witnessing the results, it is very handy and I will continue to use it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×